Commit 9658f5eb authored by Roland Haas's avatar Roland Haas
Browse files

document python 2 and python 3 support

parent 30d17379
......@@ -14,13 +14,13 @@ Installation
You can use pip wiht this repository to install the package:
```#bash
pip3 install git+https://git.ncsa.illinois.edu/bw-seas/globustransferhelper
pip install git+https://git.ncsa.illinois.edu/bw-seas/globustransferhelper
```
Usage
-----
When used as a python(3) module the helper is used like this:
When used as a python (2 or 3) module the helper is used like this:
```#python
import globustransferhelper
......
#!/usr/bin/env python3
#!/usr/bin/env python
# Copyright (c) 2019 The Board of Trustees of the University of Illinois
# All rights reserved.
......
......@@ -15,10 +15,11 @@ setuptools.setup(
py_modules=["globustransferhelper"],
scripts=["showcase_helper.py"],
classifiers=[
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 3",
"License :: OSI Approved :: NCSA License",
"Operating System :: OS Independent",
],
python_requires='>=3.0',
python_requires='>=2.7',
install_requires=["globus-sdk"],
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment